xDuoo X3 II – Doesn’t Boot up

Home Forums Ask your question xDuoo X3 II – Doesn’t Boot up

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #3037
    FoxyFox
    Participant

    Hello, i’m having an issue with my X3 II – since i made a bios update to the latest version i have big trouble to get the device to boot up.

    I press power on, then i see a screen with : ‘Updater V 1.1’
    ‘Insert TF Pls’

    i’m stuck on this screeen, it doesn’t boot, i hold ‘power on’ button to restart the device, i get stuck again and again and again. The only thing that helps, is connecting the device over the usb-c cable to my computer. When i restart the device, it does boot to the welcome screeen and get’s recognized by my pc. After that it’s usable – for a few on/off operations, after a while it’s not booting again.

    I know this ‘updater V 1.1’ screen is from bios-update, i got that because the usb cable wasn’t pluged in to a power supply. But even after i did the bios-update right, it’s comming back. I did 2 or 3 times this bios update. I’m getting still stuck in boot up with the screen even when there is not anymore an update file on the sd-card.
    An another observation i made is: When i read the sd-card with my windows pc, windows does ask for a checkdisk on it, after that it get’s readable.

    I own 2 different sc-card, wich both worked fine with device before i updated bios.
    I tried to format them on windows pc with NTFS and exfat – no effect, the screen is blocking the boot.

    Any idea what’s wrong with my xduo X3 II – i’m running out of ideas.

    Can i revert the bios update maybe (v1.3)? since the old version worked.

    beste regards

    #3302
    xDuoo Official
    Senior Moderator

    Please contact [email protected], he will give you an update tool

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.